I am LAZY bones ? all linux

perl升级引起的gentoo编译错误

最近,gentoo portage里的perl从 5.8.8 版本升到了 5.10.1 ,导致在编译一些其他包的时候,出现一些莫名的错误,而且这些错误都和perl有关。
例如,在 emerge gnome-extra/gnome-screensaver-2.28.3 的时候,就会出现:

checking for XML::Parser… configure: error: XML::Parser perl module is required for intltool

这样的错误。
解决办法是emerge一个 perl-cleaner,然后执行:

sudo perl-cleaner --all

把perl相关的模块和文件都检查并修正一遍,然后再编译其他包,就不会出错了。

最后修改时间: 2010年02月17日 19:41

本文章发表于: 2010年02月17日 19:41 | 所属分类:gentoo, 流水帐. | 您可以在此订阅本文章的所有评论. | 您也可以发表评论, 或从您的网站trackback.

4 个评论 关于: “perl升级引起的gentoo编译错误”

  1. perl升級引起的gentoo編譯錯誤 | 新蜂 Linux 在 2010年02月17日 21:07 说:回复

    […] 剛才發現一個更專業的解決辦法,來自perl升级引起的gentoo编译错误: […]

  2. 雕啸长空 在 2010年02月20日 11:24 说:回复

    有骨头大牛先行先试,生活真是美好啊。。。。

    • bones7456 在 2010年02月21日 21:21 说:回复

      雕大牛不是用windows去了吗?

  3. anjiannian 在 2010年06月07日 01:35 说:回复

    哎呀呀,哎呀呀,gconf终于不econf failed的了

发表评论