没啥意思的站点

perl升级引起的gentoo编译错误

最近,gentoo portage里的perl从 5.8.8 版本升到了 5.10.1 ,导致在编译一些其他包的时候,出现一些莫名的错误,而且这些错误都和perl有关。
例如,在 emerge gnome-extra/gnome-screensaver-2.28.3 的时候,就会出现:

checking for XML::Parser… configure: error: XML::Parser perl module is required for intltool

这样的错误。
解决办法是emerge一个 perl-cleaner,然后执行:

sudo perl-cleaner --all

把perl相关的模块和文件都检查并修正一遍,然后再编译其他包,就不会出错了。

3 评论

  1. 有骨头大牛先行先试,生活真是美好啊。。。。

  2. 哎呀呀,哎呀呀,gconf终于不econf failed的了

发表评论